<!DOCTYPE html><html lang="en"><head><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
                new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
                j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
                'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
                })(window,document,'script','dataLayer', 'GTM-T52Z3Z3');</script><script>
              window.canRunAds = true;
              window.gAdsNetworkId = '3834/gamasutra.home';
              window.adsPattern = 'homepage';</script><link rel="preconnect" href="https://fonts.googleapis.com"/><link rel="preconnect" href="https://fonts.gstatic.com"/><link rel="stylesheet" data-href="https://fonts.googleapis.com/css2?family=Poppins:ital,wght@0,100;0,200;0,300;0,400;0,500;0,600;0,700;0,800;0,900;1,100;1,200;1,300;1,400;1,500;1,600;1,700;1,800;1,900&amp;display=swap"/><meta charSet="utf-8"/><link rel="canonical" href="https://www.gamedeveloper.com/production/activision-has-created-a-kernel-level-anti-cheat-system-for-call-of-duty"/><meta property="og:url" content="https://www.gamedeveloper.com/production/activision-has-created-a-kernel-level-anti-cheat-system-for-call-of-duty"/><link rel="preconnect" href="https://www.gamedeveloper.com"/><link rel="dns-prefetch" href="https://www.gamedeveloper.com"/><link rel="shortcut icon" href="/favicon-32x32.ico"/><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no"/><meta name="google-site-verification" content="-oUwE-zKCnKfEGLTxOjxWjlZWCGRPnnhxLaLvLnhmdM"/><title>Activision has created a kernel-level anti-cheat system for Call of Duty</title><meta name="twitter:card" content="summary"/><meta property="og:site_name" content="Game Developer"/><meta property="og:type" content="article"/><meta property="og:image" content="https://eu-images.contentstack.com/v3/assets/blt95b381df7c12c15d/blt2fa90bdba23507fc/6168173779367711c6e90962/Rico_Anti_Cheat.png"/><meta property="article:published_time" content="2021-10-14T11:29:22.000Z"/><meta property="article:modified_time" content="2021-10-14T14:10:41.846Z"/><meta property="article:author" content="https://www.gamedeveloper.com/author/chris-kerr"/><meta property="article:section" content="production"/><meta property="article:tag" content="production"/><meta property="article:tag" content="console"/><meta property="article:tag" content="pc"/><meta name="title" content="Activision has created a kernel-level anti-cheat system for Call of Duty"/><meta property="og:title" content="Activision has created a kernel-level anti-cheat system for Call of Duty"/><meta name="description" content="The system, dubbed &#x27;Ricochet,&#x27; will also incorporate server-side and backend tools."/><meta property="og:description" content="The system, dubbed &#x27;Ricochet,&#x27; will also incorporate server-side and backend tools."/><meta name="keywords" content=""/><meta property="og:keywords" content=""/><meta name="next-head-count" content="26"/><link rel="preload" href="https://www.gamedeveloper.com/_next/static/css/6aa5fb3f5b2293cf6086.css" as="style"/><link rel="stylesheet" href="https://www.gamedeveloper.com/_next/static/css/6aa5fb3f5b2293cf6086.css" data-n-g=""/><noscript data-n-css=""></noscript><link rel="preload" href="https://www.gamedeveloper.com/_next/static/chunks/webpack-47bce83ba23872c700ce.js" as="script"/><link rel="preload" href="https://www.gamedeveloper.com/_next/static/chunks/framework.efe182f2d62be1d8151a.js" as="script"/><link rel="preload" href="https://www.gamedeveloper.com/_next/static/chunks/405cc4cae2d9cefca885a3d03486a84054bb08bb.57f55179cc1f11928509.js" as="script"/><link rel="preload" href="https://www.gamedeveloper.com/_next/static/chunks/85c6f8fb922b6017aaa86837ce5896a534f77b02.129bddf45142da3a0709.js" as="script"/><link rel="preload" href="https://www.gamedeveloper.com/_next/static/chunks/main-7712fa30b8b947729c3a.js" as="script"/><link rel="preload" href="https://www.gamedeveloper.com/_next/static/chunks/29107295.f607d0242cf52a473e6a.js" as="script"/><link rel="preload" href="https://www.gamedeveloper.com/_next/static/chunks/75fc9c18.8f193e2393b07d969f29.js" as="script"/><link rel="preload" href="https://www.gamedeveloper.com/_next/static/chunks/72ca276a49ee30555249b62eec69910dcf744519.8ea633e330984d910dfd.js" as="script"/><link rel="preload" href="https://www.gamedeveloper.com/_next/static/chunks/34ed02caea4d7fb2f7667818f991ac468d15d9e2.acd4d4313dd55c874d38.js" as="script"/><link rel="preload" href="https://www.gamedeveloper.com/_next/static/chunks/pages/_app-8c0258683d485206ea72.js" as="script"/><link rel="preload" href="https://www.gamedeveloper.com/_next/static/chunks/1d137d3c2b42d89e594dd08d6a7e9bce6953895a.970ec15ec64d310fceb6.js" as="script"/><link rel="preload" href="https://www.gamedeveloper.com/_next/static/chunks/bb0110fccfbf064cd16b56f4717ff6b330e5e6c1.19aa060e658c9969a1d3.js" as="script"/><link rel="preload" href="https://www.gamedeveloper.com/_next/static/chunks/2b04dd72bf30b22157c26b953ab44337c7dc546c.dcfd80b3b171fc95e123.js" as="script"/><link rel="preload" href="https://www.gamedeveloper.com/_next/static/chunks/1aa4fccfc0a9a1798e4f36db5eb709b29904984b.d501ff24a2ea33baa01b.js" as="script"/><link rel="preload" href="https://www.gamedeveloper.com/_next/static/chunks/49437bdb1112dc30b54d2e54bd767365ba8cb15b.eb16c826fa1a17164099.js" as="script"/><link rel="preload" href="https://www.gamedeveloper.com/_next/static/chunks/pages/%5Bcategory%5D/%5BhybidPage%5D-906e4671b95c6b73efa5.js" as="script"/><style data-href="https://fonts.googleapis.com/css2?family=Poppins:ital,wght@0,100;0,200;0,300;0,400;0,500;0,600;0,700;0,800;0,900;1,100;1,200;1,300;1,400;1,500;1,600;1,700;1,800;1,900&display=swap">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</style></head><body class="no-ads" id="document-body"><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-T52Z3Z3"
                height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="div-gpt-ad-welcome" class="informa-dfp-ads height-0" data-size="1*1" data-name="Welcome_welcome_v" data-targeting="pos=welcome_v" style="display:none"></div><div id="div-gpt-ad-wallpaper" class="informa-dfp-ads d-none" data-outofpage="true" data-name="Wallpaper_wallpaper_v" data-targeting="pos=wallpaper_v" data-mapping="1250*0=1*2" style="display:none"></div><div id="__next"><div><div class="informa-dfp-ads height-0" data-outofpage="true" data-name="article_oop_v" data-targeting="pos=oop_v" style="display:none"></div><div id="div-gpt-ad-floor" class="informa-dfp-ads height-0" data-name="Floor_Ad_floor_v" data-size="1*1" data-targeting="pos=floor_v" style="display:none"></div><div class="informa-dfp-ads height-0" data-size="7*7" data-name="mobileAdhesionBanner" data-targeting="pos=adhesion_v" id="mobile-adhesion-banner" style="display:none"></div><div id="overlay-fixed-all-screen" class="position-fixed w-100 bg-white fullscreen-overlay-fixed show-overlay"></div><div data-role="page" data-enhance="false" id="container-main" class="page-layout content-body-wrapper" style="opacity:0"><div><div id="header-wrap"><header class="header"><div class="header-main d-flex justify-content-center align-items-center"><div class="h-100 cursor-pointer d-flex justify-content-center align-items-center"><img src="https://www.gamedeveloper.com/images/iribbon-logo.png" alt="informa" width="72px" height="16px"/><i class="fas fa-caret-down text-white ml-2"></i></div></div><div class="header-secondary"><div class="bg-nav d-none"></div><div class="container pt-0 pb-0 h-100"><div class="row align-items-center flex-nowrap h-100"><div class="inner-logo-wrapper"><a title="GD" href="/" class="h-100"><div class="lazyload-wrapper "><div style="height:24px" class="lazyload-placeholder"></div></div></a></div><div class="row navigation-menu"><div class="w-100"><nav class="pr-0 pl-0 pb-0 pt-0 navbar navbar-expand navbar-light"><div class="d-flex category-list w-100 navbar-nav"><div class="menu-item feature-link d-flex align-items-center"><a href="https://jobs.gamasutra.com" class="nav-link d-flex pr-3 align-items-center justify-content-center" title="Jobs">Jobs</a></div><div class="menu-item topics d-flex align-items-center "><div class="d-flex align-items-center w-100"><span class="nav-link d-flex pr-3 align-items-center justify-content-center w-100" title="Sections">Sections<svg width="8" height="5" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-up ml-1"><path d="M7.872 4.276l-.262.261a.437.437 0 01-.31.126.438.438 0 01-.309-.126l-2.99-2.952L1.01 4.54a.437.437 0 01-.31.127.437.437 0 01-.309-.127l-.262-.259a.429.429 0 010-.61L3.691.137A.45.45 0 014.001 0h.002a.45.45 0 01.31.138l3.56 3.523a.434.434 0 010 .615z" fill="#E60012"></path></svg><svg width="8" height="5" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-down ml-1"><path d="M7.872.39L7.61.13A.437.437 0 007.3.002a.438.438 0 00-.309.126l-2.99 2.953L1.01.126A.437.437 0 00.7 0 .437.437 0 00.39.126l-.262.26a.429.429 0 000 .61l3.563 3.532a.45.45 0 00.31.139h.002a.45.45 0 00.31-.139l3.56-3.522a.434.434 0 000-.616z" fill="#fff"></path></svg></span><div class="expand-menu" style="display:none"><div class="container px-0"><div class="row head justify-content-between align-items-center mx-0"><span class="close-button">Close<svg width="10" height="10" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M9 1L1 9m8 0L1 1" stroke="#0B0B0B" stroke-width="2" stroke-miterlimit="10" stroke-linecap="round"></path></svg></span><div class="back-button"><svg width="14" height="14" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M6.999 1.445a5.556 5.556 0 110 11.11 5.556 5.556 0 010-11.11zM13.665 7A6.667 6.667 0 10.331 7a6.667 6.667 0 0013.334 0zm-4.444.556a.556.556 0 000-1.111H6.118l.718-.719a.556.556 0 00-.786-.785L4.384 6.608a.556.556 0 000 .785L6.05 9.06a.556.556 0 00.786-.786l-.718-.718H9.22z" fill="#212324"></path></svg>Back</div><div class="menu-title">Sections</div></div><div class="row casual-links mx-0"><div class="topic-group"><a href="https://www.gamedeveloper.com/disciplines" class="nav-link primary" title="Disciplines">Disciplines</a><div class="secondary-topic-group"><a title="Programming" class="nav-link secondary" href="https://www.gamedeveloper.com/programming">Programming</a><a title="Design" class="nav-link secondary" href="https://www.gamedeveloper.com/design">Design</a><a title="Audio" class="nav-link secondary" href="https://www.gamedeveloper.com/audio">Audio</a><a title="Art" class="nav-link secondary" href="https://www.gamedeveloper.com/art">Art</a><a title="Production" class="nav-link secondary" href="https://www.gamedeveloper.com/production">Production</a><a title="Business" class="nav-link secondary" href="https://www.gamedeveloper.com/business">Business</a></div><div class="icon-container for-mobile"><svg width="14" height="13" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-up" style="display:none"><path fill-rule="evenodd" clip-rule="evenodd" d="M.448 7C.448 3.324 3.416.333 7.063.333 10.711.333 13.68 3.324 13.68 7a6.65 6.65 0 01-3.608 5.94.55.55 0 01-.742-.242.558.558 0 01.24-.747A5.542 5.542 0 0012.576 7c0-3.064-2.473-5.556-5.513-5.556S1.551 3.937 1.551 7a5.542 5.542 0 003.007 4.95c.27.14.378.474.24.747a.549.549 0 01-.742.242A6.65 6.65 0 01.448 7zm9.205.436a.559.559 0 01.01.785.549.549 0 01-.78.01L7.068 6.45 5.243 8.232a.548.548 0 01-.78-.01.559.559 0 01.01-.786L6.29 5.654a1.098 1.098 0 011.554.005l1.81 1.777z" fill="#000"></path></svg><svg width="14" height="13" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-down" style="display:block"><path fill-rule="evenodd" clip-rule="evenodd" d="M13.668 6A6.675 6.675 0 017 12.667 6.675 6.675 0 01.334 6 6.644 6.644 0 013.97.06a.555.555 0 11.506.99A5.537 5.537 0 001.446 6 5.562 5.562 0 007 11.554 5.562 5.562 0 0012.557 6a5.537 5.537 0 00-3.03-4.95.556.556 0 01.505-.989A6.644 6.644 0 0113.668 6zM4.39 5.564a.556.556 0 11.776-.796l1.83 1.782 1.839-1.782a.556.556 0 11.775.796l-1.83 1.782a1.111 1.111 0 01-1.566-.005L4.391 5.564z" fill="#000"></path></svg></div><div class="secondary-topic-group for-mobile" style="display:none"><a title="Programming" class="nav-link secondary" href="https://www.gamedeveloper.com/programming">Programming</a><a title="Design" class="nav-link secondary" href="https://www.gamedeveloper.com/design">Design</a><a title="Audio" class="nav-link secondary" href="https://www.gamedeveloper.com/audio">Audio</a><a title="Art" class="nav-link secondary" href="https://www.gamedeveloper.com/art">Art</a><a title="Production" class="nav-link secondary" href="https://www.gamedeveloper.com/production">Production</a><a title="Business" class="nav-link secondary" href="https://www.gamedeveloper.com/business">Business</a></div></div><div class="topic-group"><a href="https://www.gamedeveloper.com/topics" class="nav-link primary" title="Topics">Topics</a><div class="secondary-topic-group"><a title="Console" class="nav-link secondary" href="https://www.gamedeveloper.com/console">Console</a><a title="PC" class="nav-link secondary" href="https://www.gamedeveloper.com/pc">PC</a><a title="Mobile" class="nav-link secondary" href="https://www.gamedeveloper.com/mobile">Mobile</a><a title="Extended Reality" class="nav-link secondary" href="https://www.gamedeveloper.com/extended-reality">Extended Reality</a><a title="The Cloud" class="nav-link secondary" href="https://www.gamedeveloper.com/the-cloud">The Cloud</a><a title="Culture" class="nav-link secondary" href="https://www.gamedeveloper.com/culture">Culture</a></div><div class="icon-container for-mobile"><svg width="14" height="13" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-up" style="display:none"><path fill-rule="evenodd" clip-rule="evenodd" d="M.448 7C.448 3.324 3.416.333 7.063.333 10.711.333 13.68 3.324 13.68 7a6.65 6.65 0 01-3.608 5.94.55.55 0 01-.742-.242.558.558 0 01.24-.747A5.542 5.542 0 0012.576 7c0-3.064-2.473-5.556-5.513-5.556S1.551 3.937 1.551 7a5.542 5.542 0 003.007 4.95c.27.14.378.474.24.747a.549.549 0 01-.742.242A6.65 6.65 0 01.448 7zm9.205.436a.559.559 0 01.01.785.549.549 0 01-.78.01L7.068 6.45 5.243 8.232a.548.548 0 01-.78-.01.559.559 0 01.01-.786L6.29 5.654a1.098 1.098 0 011.554.005l1.81 1.777z" fill="#000"></path></svg><svg width="14" height="13" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-down" style="display:block"><path fill-rule="evenodd" clip-rule="evenodd" d="M13.668 6A6.675 6.675 0 017 12.667 6.675 6.675 0 01.334 6 6.644 6.644 0 013.97.06a.555.555 0 11.506.99A5.537 5.537 0 001.446 6 5.562 5.562 0 007 11.554 5.562 5.562 0 0012.557 6a5.537 5.537 0 00-3.03-4.95.556.556 0 01.505-.989A6.644 6.644 0 0113.668 6zM4.39 5.564a.556.556 0 11.776-.796l1.83 1.782 1.839-1.782a.556.556 0 11.775.796l-1.83 1.782a1.111 1.111 0 01-1.566-.005L4.391 5.564z" fill="#000"></path></svg></div><div class="secondary-topic-group for-mobile" style="display:none"><a title="Console" class="nav-link secondary" href="https://www.gamedeveloper.com/console">Console</a><a title="PC" class="nav-link secondary" href="https://www.gamedeveloper.com/pc">PC</a><a title="Mobile" class="nav-link secondary" href="https://www.gamedeveloper.com/mobile">Mobile</a><a title="Extended Reality" class="nav-link secondary" href="https://www.gamedeveloper.com/extended-reality">Extended Reality</a><a title="The Cloud" class="nav-link secondary" href="https://www.gamedeveloper.com/the-cloud">The Cloud</a><a title="Culture" class="nav-link secondary" href="https://www.gamedeveloper.com/culture">Culture</a></div></div></div><div class="row promoted-links mx-0"><div class="topic-group"><a href="https://www.gamedeveloper.com/latest/news" class="nav-link promoted" title="[News]">[News]</a></div><div class="topic-group"><a href="https://www.gamedeveloper.com/latest/features" class="nav-link promoted" title="[Features]">[Features]</a></div><div class="topic-group"><a href="https://www.gamedeveloper.com/latest/developer-insights" class="nav-link promoted" title="[Developer Insights]">[Developer Insights]</a></div><div class="topic-group"><a href="https://gamasutra.com/pressreleases_index.php" class="nav-link promoted" title="[Press Releases] &gt;">[Press Releases] &gt;</a></div><div class="topic-group"><a href="https://www.gamecareerguide.com/" class="nav-link promoted" title="[Game Career Guide] &gt;">[Game Career Guide] &gt;</a></div></div></div></div></div></div><div class="menu-item reports d-flex align-items-center "><div class="d-flex align-items-center w-100"><span class="nav-link d-flex pr-3 align-items-center justify-content-center w-100" title="Blogs">Blogs<svg width="8" height="5" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-up ml-1"><path d="M7.872 4.276l-.262.261a.437.437 0 01-.31.126.438.438 0 01-.309-.126l-2.99-2.952L1.01 4.54a.437.437 0 01-.31.127.437.437 0 01-.309-.127l-.262-.259a.429.429 0 010-.61L3.691.137A.45.45 0 014.001 0h.002a.45.45 0 01.31.138l3.56 3.523a.434.434 0 010 .615z" fill="#E60012"></path></svg><svg width="8" height="5" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-down ml-1"><path d="M7.872.39L7.61.13A.437.437 0 007.3.002a.438.438 0 00-.309.126l-2.99 2.953L1.01.126A.437.437 0 00.7 0 .437.437 0 00.39.126l-.262.26a.429.429 0 000 .61l3.563 3.532a.45.45 0 00.31.139h.002a.45.45 0 00.31-.139l3.56-3.522a.434.434 0 000-.616z" fill="#fff"></path></svg></span><div class="expand-menu" style="display:none"><div class="container px-0"><div class="row head justify-content-between align-items-center mx-0"><span class="close-button">Close<svg width="10" height="10" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M9 1L1 9m8 0L1 1" stroke="#0B0B0B" stroke-width="2" stroke-miterlimit="10" stroke-linecap="round"></path></svg></span><div class="back-button"><svg width="14" height="14" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M6.999 1.445a5.556 5.556 0 110 11.11 5.556 5.556 0 010-11.11zM13.665 7A6.667 6.667 0 10.331 7a6.667 6.667 0 0013.334 0zm-4.444.556a.556.556 0 000-1.111H6.118l.718-.719a.556.556 0 00-.786-.785L4.384 6.608a.556.556 0 000 .785L6.05 9.06a.556.556 0 00.786-.786l-.718-.718H9.22z" fill="#212324"></path></svg>Back</div><div class="menu-title">Blogs</div></div><div class="row report-links py-4 mx-0"><div class="link-group col-12 col-md-3 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_blank" href="https://www.gamedeveloper.com/blogs">[All Blogs]</a></div><div class="link-group col-12 col-md-3 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_blank" href="https://www.gamasutra.com/static2/blogsubmissions.html">Write for Game Developer</a></div><div class="link-group col-12 col-md-3 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_blank" href="https://gamasutra.com/blogs/edit/blog/item/">Blog Now</a></div></div></div></div></div></div><div class="menu-item connect d-flex align-items-center "><div class="d-flex align-items-center w-100"><span class="nav-link d-flex pr-3 align-items-center justify-content-center w-100" title="Connect">Connect<svg width="8" height="5" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-up ml-1"><path d="M7.872 4.276l-.262.261a.437.437 0 01-.31.126.438.438 0 01-.309-.126l-2.99-2.952L1.01 4.54a.437.437 0 01-.31.127.437.437 0 01-.309-.127l-.262-.259a.429.429 0 010-.61L3.691.137A.45.45 0 014.001 0h.002a.45.45 0 01.31.138l3.56 3.523a.434.434 0 010 .615z" fill="#E60012"></path></svg><svg width="8" height="5" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-down ml-1"><path d="M7.872.39L7.61.13A.437.437 0 007.3.002a.438.438 0 00-.309.126l-2.99 2.953L1.01.126A.437.437 0 00.7 0 .437.437 0 00.39.126l-.262.26a.429.429 0 000 .61l3.563 3.532a.45.45 0 00.31.139h.002a.45.45 0 00.31-.139l3.56-3.522a.434.434 0 000-.616z" fill="#fff"></path></svg></span><div class="expand-menu" style="display:none"><div class="container px-0"><div class="row head justify-content-between align-items-center mx-0"><span class="close-button">Close<svg width="10" height="10" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M9 1L1 9m8 0L1 1" stroke="#0B0B0B" stroke-width="2" stroke-miterlimit="10" stroke-linecap="round"></path></svg></span><div class="back-button"><svg width="14" height="14" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M6.999 1.445a5.556 5.556 0 110 11.11 5.556 5.556 0 010-11.11zM13.665 7A6.667 6.667 0 10.331 7a6.667 6.667 0 0013.334 0zm-4.444.556a.556.556 0 000-1.111H6.118l.718-.719a.556.556 0 00-.786-.785L4.384 6.608a.556.556 0 000 .785L6.05 9.06a.556.556 0 00.786-.786l-.718-.718H9.22z" fill="#212324"></path></svg>Back</div><div class="menu-title">Connect</div></div><div class="row brand-engagement-section mx-0"><div class="brand-engagement-module d-flex flex-row flex-wrap"><div class="module-item"><div class="module-item-eyebrow">Register for a</div><div class="module-item-title">Game Developer Account</div><div class="module-item-description"><div><p>Gain full access to resources (events, white paper, webinars, reports, etc)<br>Single sign-on to all Informa products</p>

</div></div><div class="module-item-button"><a class="dr-btn text-decoration-none text-white" target="_blank" href="https://www.gamasutra.com/php-bin/sso/join.php" rel="noreferrer">Register</a></div></div><div class="module-item"><div class="module-item-eyebrow">Subscribe to</div><div class="module-item-title">Game Developer Newsletter</div><div class="module-item-description"><div>
<p>Get daily Game Developer top stories every morning straight into your inbox</p>
</div></div><div class="module-item-button"><a class="dr-btn text-decoration-none text-white" target="_blank" href="https://www.gamasutra.com/newsletter-signup" rel="noreferrer">Subscribe</a></div></div><div class="module-item"><div class="module-item-eyebrow">Follow us</div><div class="module-item-title">@gamedevdotcom</div><div class="module-item-description"><div>
<p>Follow us @gamedevdotcom to stay up-to-date with the latest news & insider information about events & more</p>
</div></div><div class="sns-container d-flex"><div class="rss-wrap sns-link"><a class="d-flex justify-content-center align-items-center" href="https://www.gamedeveloper.com/rss.xml" rel="noreferrer" title="RSS" target="_target"><i class="text-white fas fa-rss"></i></a></div><div class="twitter-wrap sns-link"><a class="d-flex justify-content-center align-items-center" href="https://twitter.com/gamedevdotcom" rel="noreferrer" title="Twitter" target="_target"><i class="text-white fab fa-twitter"></i></a></div><div class="linkedin-wrap sns-link"><a class="d-flex justify-content-center align-items-center" href="https://www.linkedin.com/company/gamasutra/" rel="noreferrer" title="Linkedin" target="_target"><i class="text-white fab fa-linkedin-in"></i></a></div><div class="facebook-wrap sns-link"><a class="d-flex justify-content-center align-items-center" href="https://www.facebook.com/GamasutraOfficial/" rel="noreferrer" title="Facebook" target="_target"><i class="text-white fab fa-facebook-f"></i></a></div></div></div></div></div><div class="row connect-links py-4 mx-0"><div class="link-group col-12 col-md-4 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_blank" href="https://www.gamedeveloper.com/about-game-developer">About Us</a></div><div class="link-group col-12 col-md-4 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_blank" href="https://www.gamedeveloper.com/advertise-with-us">Advertise With Us</a></div><div class="link-group col-12 col-md-4 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_self" href="https://www.gamedeveloper.com/report-an-issue">Report An Issue</a></div></div><div class="row our-network-section mx-0"><div class="label">Our Network:</div><div class="networks w-100 d-flex"><div class="our-network-item"><a target="_blank" href="https://gdconf.com" title="GDC" class="d-flex align-items-center" rel="noreferrer"><img isnotlazyload="true" src="https://eu-images.contentstack.com/v3/assets/blt95b381df7c12c15d/blt64f777be7073c715/6126883beb5e7a021d3cf779/GDC_logo_k.png" alt="GDC Logo" width="auto" height="32"/><span class="d-none">https://eu-images.contentstack.com/v3/assets/blt95b381df7c12c15d/blt64f777be7073c715/6126883beb5e7a021d3cf779/GDC_logo_k.png</span></a></div><div class="our-network-item"><a target="_blank" href="https://www.gdcvault.com" title="GDC Vault" class="d-flex align-items-center" rel="noreferrer"><img isnotlazyload="true" src="https://eu-images.contentstack.com/v3/assets/blt95b381df7c12c15d/blte556a65784279a9b/61268827eb5e7a021d3cf775/masthead_logo.png" alt="GDC Vault Logo" width="auto" height="32"/><span class="d-none">https://eu-images.contentstack.com/v3/assets/blt95b381df7c12c15d/blte556a65784279a9b/61268827eb5e7a021d3cf775/masthead_logo.png</span></a></div></div></div></div></div></div></div><span class="search-icon"><svg width="15" height="15" fill="none" xmlns="http://www.w3.org/2000/svg" class="ml-2"><path d="M6.286.214a6.071 6.071 0 014.768 9.83l3.237 3.237a.714.714 0 01-1.01 1.01l-3.237-3.237A6.071 6.071 0 116.285.214zm0 1.429a4.643 4.643 0 100 9.286 4.643 4.643 0 000-9.286z" fill="#fff"></path></svg></span></div></nav></div></div><div class="flex-grow-1"></div><span class="search-icon"><svg width="15" height="15" fill="none" xmlns="http://www.w3.org/2000/svg" class="ml-2"><path d="M6.286.214a6.071 6.071 0 014.768 9.83l3.237 3.237a.714.714 0 01-1.01 1.01l-3.237-3.237A6.071 6.071 0 116.285.214zm0 1.429a4.643 4.643 0 100 9.286 4.643 4.643 0 000-9.286z" fill="#fff"></path></svg></span><a class="newsletter-sign-up iw-btn text-decoration-none" href="https://www.gamasutra.com/newsletter-signup" target="_blank" rel="noreferrer">Subscribe</a><div class="h-100 d-flex align-items-center ml-1"><div class="cursor-pointer login-text">Login</div><div class="text-white">/</div><div class="cursor-pointer login-text">Register</div></div></div></div></div><div class="header-secondary-mobile align-items-center"><div class="container"><div class="row"><div class="logo-wrapper d-flex justify-content-between"><div class="main-logo"><a title="GD" href="/"><div class="lazyload-wrapper "><div style="height:24px" class="lazyload-placeholder"></div></div></a></div><span class="search-icon"><svg width="15" height="15" fill="none" xmlns="http://www.w3.org/2000/svg" class="ml-2"><path d="M6.286.214a6.071 6.071 0 014.768 9.83l3.237 3.237a.714.714 0 01-1.01 1.01l-3.237-3.237A6.071 6.071 0 116.285.214zm0 1.429a4.643 4.643 0 100 9.286 4.643 4.643 0 000-9.286z" fill="#fff"></path></svg></span><div class="cursor-pointer function-wrapper"><svg width="20" height="16" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M18.5 14a1 1 0 110 2h-17a1 1 0 110-2h17zm0-7a1 1 0 110 2h-17a1 1 0 110-2h17zm0-7a1 1 0 110 2h-17a1 1 0 010-2h17z" fill="#fff"></path></svg></div></div></div></div></div></header><div class="navigation"><div class="container d-flex flex-column justify-content-between pb-0 pt-0"><div class="row navigation-menu"><div class="w-100"><nav class="pr-0 pl-0 pb-0 pt-0 navbar navbar-expand navbar-light"><div class="d-flex category-list w-100 navbar-nav"><div class="menu-item feature-link d-flex align-items-center"><a href="https://jobs.gamasutra.com" class="nav-link d-flex pr-3 align-items-center justify-content-center" title="Jobs">Jobs</a></div><div class="menu-item topics d-flex align-items-center "><div class="d-flex align-items-center w-100"><span class="nav-link d-flex pr-3 align-items-center justify-content-center w-100" title="Sections">Sections<svg width="8" height="5" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-up ml-1"><path d="M7.872 4.276l-.262.261a.437.437 0 01-.31.126.438.438 0 01-.309-.126l-2.99-2.952L1.01 4.54a.437.437 0 01-.31.127.437.437 0 01-.309-.127l-.262-.259a.429.429 0 010-.61L3.691.137A.45.45 0 014.001 0h.002a.45.45 0 01.31.138l3.56 3.523a.434.434 0 010 .615z" fill="#E60012"></path></svg><svg width="8" height="5" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-down ml-1"><path d="M7.872.39L7.61.13A.437.437 0 007.3.002a.438.438 0 00-.309.126l-2.99 2.953L1.01.126A.437.437 0 00.7 0 .437.437 0 00.39.126l-.262.26a.429.429 0 000 .61l3.563 3.532a.45.45 0 00.31.139h.002a.45.45 0 00.31-.139l3.56-3.522a.434.434 0 000-.616z" fill="#fff"></path></svg></span><div class="expand-menu" style="display:none"><div class="container px-0"><div class="row head justify-content-between align-items-center mx-0"><span class="close-button">Close<svg width="10" height="10" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M9 1L1 9m8 0L1 1" stroke="#0B0B0B" stroke-width="2" stroke-miterlimit="10" stroke-linecap="round"></path></svg></span><div class="back-button"><svg width="14" height="14" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M6.999 1.445a5.556 5.556 0 110 11.11 5.556 5.556 0 010-11.11zM13.665 7A6.667 6.667 0 10.331 7a6.667 6.667 0 0013.334 0zm-4.444.556a.556.556 0 000-1.111H6.118l.718-.719a.556.556 0 00-.786-.785L4.384 6.608a.556.556 0 000 .785L6.05 9.06a.556.556 0 00.786-.786l-.718-.718H9.22z" fill="#212324"></path></svg>Back</div><div class="menu-title">Sections</div></div><div class="row casual-links mx-0"><div class="topic-group"><a href="https://www.gamedeveloper.com/disciplines" class="nav-link primary" title="Disciplines">Disciplines</a><div class="secondary-topic-group"><a title="Programming" class="nav-link secondary" href="https://www.gamedeveloper.com/programming">Programming</a><a title="Design" class="nav-link secondary" href="https://www.gamedeveloper.com/design">Design</a><a title="Audio" class="nav-link secondary" href="https://www.gamedeveloper.com/audio">Audio</a><a title="Art" class="nav-link secondary" href="https://www.gamedeveloper.com/art">Art</a><a title="Production" class="nav-link secondary" href="https://www.gamedeveloper.com/production">Production</a><a title="Business" class="nav-link secondary" href="https://www.gamedeveloper.com/business">Business</a></div><div class="icon-container for-mobile"><svg width="14" height="13" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-up" style="display:none"><path fill-rule="evenodd" clip-rule="evenodd" d="M.448 7C.448 3.324 3.416.333 7.063.333 10.711.333 13.68 3.324 13.68 7a6.65 6.65 0 01-3.608 5.94.55.55 0 01-.742-.242.558.558 0 01.24-.747A5.542 5.542 0 0012.576 7c0-3.064-2.473-5.556-5.513-5.556S1.551 3.937 1.551 7a5.542 5.542 0 003.007 4.95c.27.14.378.474.24.747a.549.549 0 01-.742.242A6.65 6.65 0 01.448 7zm9.205.436a.559.559 0 01.01.785.549.549 0 01-.78.01L7.068 6.45 5.243 8.232a.548.548 0 01-.78-.01.559.559 0 01.01-.786L6.29 5.654a1.098 1.098 0 011.554.005l1.81 1.777z" fill="#000"></path></svg><svg width="14" height="13" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-down" style="display:block"><path fill-rule="evenodd" clip-rule="evenodd" d="M13.668 6A6.675 6.675 0 017 12.667 6.675 6.675 0 01.334 6 6.644 6.644 0 013.97.06a.555.555 0 11.506.99A5.537 5.537 0 001.446 6 5.562 5.562 0 007 11.554 5.562 5.562 0 0012.557 6a5.537 5.537 0 00-3.03-4.95.556.556 0 01.505-.989A6.644 6.644 0 0113.668 6zM4.39 5.564a.556.556 0 11.776-.796l1.83 1.782 1.839-1.782a.556.556 0 11.775.796l-1.83 1.782a1.111 1.111 0 01-1.566-.005L4.391 5.564z" fill="#000"></path></svg></div><div class="secondary-topic-group for-mobile" style="display:none"><a title="Programming" class="nav-link secondary" href="https://www.gamedeveloper.com/programming">Programming</a><a title="Design" class="nav-link secondary" href="https://www.gamedeveloper.com/design">Design</a><a title="Audio" class="nav-link secondary" href="https://www.gamedeveloper.com/audio">Audio</a><a title="Art" class="nav-link secondary" href="https://www.gamedeveloper.com/art">Art</a><a title="Production" class="nav-link secondary" href="https://www.gamedeveloper.com/production">Production</a><a title="Business" class="nav-link secondary" href="https://www.gamedeveloper.com/business">Business</a></div></div><div class="topic-group"><a href="https://www.gamedeveloper.com/topics" class="nav-link primary" title="Topics">Topics</a><div class="secondary-topic-group"><a title="Console" class="nav-link secondary" href="https://www.gamedeveloper.com/console">Console</a><a title="PC" class="nav-link secondary" href="https://www.gamedeveloper.com/pc">PC</a><a title="Mobile" class="nav-link secondary" href="https://www.gamedeveloper.com/mobile">Mobile</a><a title="Extended Reality" class="nav-link secondary" href="https://www.gamedeveloper.com/extended-reality">Extended Reality</a><a title="The Cloud" class="nav-link secondary" href="https://www.gamedeveloper.com/the-cloud">The Cloud</a><a title="Culture" class="nav-link secondary" href="https://www.gamedeveloper.com/culture">Culture</a></div><div class="icon-container for-mobile"><svg width="14" height="13" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-up" style="display:none"><path fill-rule="evenodd" clip-rule="evenodd" d="M.448 7C.448 3.324 3.416.333 7.063.333 10.711.333 13.68 3.324 13.68 7a6.65 6.65 0 01-3.608 5.94.55.55 0 01-.742-.242.558.558 0 01.24-.747A5.542 5.542 0 0012.576 7c0-3.064-2.473-5.556-5.513-5.556S1.551 3.937 1.551 7a5.542 5.542 0 003.007 4.95c.27.14.378.474.24.747a.549.549 0 01-.742.242A6.65 6.65 0 01.448 7zm9.205.436a.559.559 0 01.01.785.549.549 0 01-.78.01L7.068 6.45 5.243 8.232a.548.548 0 01-.78-.01.559.559 0 01.01-.786L6.29 5.654a1.098 1.098 0 011.554.005l1.81 1.777z" fill="#000"></path></svg><svg width="14" height="13" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-down" style="display:block"><path fill-rule="evenodd" clip-rule="evenodd" d="M13.668 6A6.675 6.675 0 017 12.667 6.675 6.675 0 01.334 6 6.644 6.644 0 013.97.06a.555.555 0 11.506.99A5.537 5.537 0 001.446 6 5.562 5.562 0 007 11.554 5.562 5.562 0 0012.557 6a5.537 5.537 0 00-3.03-4.95.556.556 0 01.505-.989A6.644 6.644 0 0113.668 6zM4.39 5.564a.556.556 0 11.776-.796l1.83 1.782 1.839-1.782a.556.556 0 11.775.796l-1.83 1.782a1.111 1.111 0 01-1.566-.005L4.391 5.564z" fill="#000"></path></svg></div><div class="secondary-topic-group for-mobile" style="display:none"><a title="Console" class="nav-link secondary" href="https://www.gamedeveloper.com/console">Console</a><a title="PC" class="nav-link secondary" href="https://www.gamedeveloper.com/pc">PC</a><a title="Mobile" class="nav-link secondary" href="https://www.gamedeveloper.com/mobile">Mobile</a><a title="Extended Reality" class="nav-link secondary" href="https://www.gamedeveloper.com/extended-reality">Extended Reality</a><a title="The Cloud" class="nav-link secondary" href="https://www.gamedeveloper.com/the-cloud">The Cloud</a><a title="Culture" class="nav-link secondary" href="https://www.gamedeveloper.com/culture">Culture</a></div></div></div><div class="row promoted-links mx-0"><div class="topic-group"><a href="https://www.gamedeveloper.com/latest/news" class="nav-link promoted" title="[News]">[News]</a></div><div class="topic-group"><a href="https://www.gamedeveloper.com/latest/features" class="nav-link promoted" title="[Features]">[Features]</a></div><div class="topic-group"><a href="https://www.gamedeveloper.com/latest/developer-insights" class="nav-link promoted" title="[Developer Insights]">[Developer Insights]</a></div><div class="topic-group"><a href="https://gamasutra.com/pressreleases_index.php" class="nav-link promoted" title="[Press Releases] &gt;">[Press Releases] &gt;</a></div><div class="topic-group"><a href="https://www.gamecareerguide.com/" class="nav-link promoted" title="[Game Career Guide] &gt;">[Game Career Guide] &gt;</a></div></div></div></div></div></div><div class="menu-item reports d-flex align-items-center "><div class="d-flex align-items-center w-100"><span class="nav-link d-flex pr-3 align-items-center justify-content-center w-100" title="Blogs">Blogs<svg width="8" height="5" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-up ml-1"><path d="M7.872 4.276l-.262.261a.437.437 0 01-.31.126.438.438 0 01-.309-.126l-2.99-2.952L1.01 4.54a.437.437 0 01-.31.127.437.437 0 01-.309-.127l-.262-.259a.429.429 0 010-.61L3.691.137A.45.45 0 014.001 0h.002a.45.45 0 01.31.138l3.56 3.523a.434.434 0 010 .615z" fill="#E60012"></path></svg><svg width="8" height="5" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-down ml-1"><path d="M7.872.39L7.61.13A.437.437 0 007.3.002a.438.438 0 00-.309.126l-2.99 2.953L1.01.126A.437.437 0 00.7 0 .437.437 0 00.39.126l-.262.26a.429.429 0 000 .61l3.563 3.532a.45.45 0 00.31.139h.002a.45.45 0 00.31-.139l3.56-3.522a.434.434 0 000-.616z" fill="#fff"></path></svg></span><div class="expand-menu" style="display:none"><div class="container px-0"><div class="row head justify-content-between align-items-center mx-0"><span class="close-button">Close<svg width="10" height="10" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M9 1L1 9m8 0L1 1" stroke="#0B0B0B" stroke-width="2" stroke-miterlimit="10" stroke-linecap="round"></path></svg></span><div class="back-button"><svg width="14" height="14" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M6.999 1.445a5.556 5.556 0 110 11.11 5.556 5.556 0 010-11.11zM13.665 7A6.667 6.667 0 10.331 7a6.667 6.667 0 0013.334 0zm-4.444.556a.556.556 0 000-1.111H6.118l.718-.719a.556.556 0 00-.786-.785L4.384 6.608a.556.556 0 000 .785L6.05 9.06a.556.556 0 00.786-.786l-.718-.718H9.22z" fill="#212324"></path></svg>Back</div><div class="menu-title">Blogs</div></div><div class="row report-links py-4 mx-0"><div class="link-group col-12 col-md-3 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_blank" href="https://www.gamedeveloper.com/blogs">[All Blogs]</a></div><div class="link-group col-12 col-md-3 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_blank" href="https://www.gamasutra.com/static2/blogsubmissions.html">Write for Game Developer</a></div><div class="link-group col-12 col-md-3 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_blank" href="https://gamasutra.com/blogs/edit/blog/item/">Blog Now</a></div></div></div></div></div></div><div class="menu-item connect d-flex align-items-center "><div class="d-flex align-items-center w-100"><span class="nav-link d-flex pr-3 align-items-center justify-content-center w-100" title="Connect">Connect<svg width="8" height="5" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-up ml-1"><path d="M7.872 4.276l-.262.261a.437.437 0 01-.31.126.438.438 0 01-.309-.126l-2.99-2.952L1.01 4.54a.437.437 0 01-.31.127.437.437 0 01-.309-.127l-.262-.259a.429.429 0 010-.61L3.691.137A.45.45 0 014.001 0h.002a.45.45 0 01.31.138l3.56 3.523a.434.434 0 010 .615z" fill="#E60012"></path></svg><svg width="8" height="5" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-down ml-1"><path d="M7.872.39L7.61.13A.437.437 0 007.3.002a.438.438 0 00-.309.126l-2.99 2.953L1.01.126A.437.437 0 00.7 0 .437.437 0 00.39.126l-.262.26a.429.429 0 000 .61l3.563 3.532a.45.45 0 00.31.139h.002a.45.45 0 00.31-.139l3.56-3.522a.434.434 0 000-.616z" fill="#fff"></path></svg></span><div class="expand-menu" style="display:none"><div class="container px-0"><div class="row head justify-content-between align-items-center mx-0"><span class="close-button">Close<svg width="10" height="10" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M9 1L1 9m8 0L1 1" stroke="#0B0B0B" stroke-width="2" stroke-miterlimit="10" stroke-linecap="round"></path></svg></span><div class="back-button"><svg width="14" height="14" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M6.999 1.445a5.556 5.556 0 110 11.11 5.556 5.556 0 010-11.11zM13.665 7A6.667 6.667 0 10.331 7a6.667 6.667 0 0013.334 0zm-4.444.556a.556.556 0 000-1.111H6.118l.718-.719a.556.556 0 00-.786-.785L4.384 6.608a.556.556 0 000 .785L6.05 9.06a.556.556 0 00.786-.786l-.718-.718H9.22z" fill="#212324"></path></svg>Back</div><div class="menu-title">Connect</div></div><div class="row brand-engagement-section mx-0"><div class="brand-engagement-module d-flex flex-row flex-wrap"><div class="module-item"><div class="module-item-eyebrow">Register for a</div><div class="module-item-title">Game Developer Account</div><div class="module-item-description"><div><p>Gain full access to resources (events, white paper, webinars, reports, etc)<br>Single sign-on to all Informa products</p>

</div></div><div class="module-item-button"><a class="dr-btn text-decoration-none text-white" target="_blank" href="https://www.gamasutra.com/php-bin/sso/join.php" rel="noreferrer">Register</a></div></div><div class="module-item"><div class="module-item-eyebrow">Subscribe to</div><div class="module-item-title">Game Developer Newsletter</div><div class="module-item-description"><div>
<p>Get daily Game Developer top stories every morning straight into your inbox</p>
</div></div><div class="module-item-button"><a class="dr-btn text-decoration-none text-white" target="_blank" href="https://www.gamasutra.com/newsletter-signup" rel="noreferrer">Subscribe</a></div></div><div class="module-item"><div class="module-item-eyebrow">Follow us</div><div class="module-item-title">@gamedevdotcom</div><div class="module-item-description"><div>
<p>Follow us @gamedevdotcom to stay up-to-date with the latest news & insider information about events & more</p>
</div></div><div class="sns-container d-flex"><div class="rss-wrap sns-link"><a class="d-flex justify-content-center align-items-center" href="https://www.gamedeveloper.com/rss.xml" rel="noreferrer" title="RSS" target="_target"><i class="text-white fas fa-rss"></i></a></div><div class="twitter-wrap sns-link"><a class="d-flex justify-content-center align-items-center" href="https://twitter.com/gamedevdotcom" rel="noreferrer" title="Twitter" target="_target"><i class="text-white fab fa-twitter"></i></a></div><div class="linkedin-wrap sns-link"><a class="d-flex justify-content-center align-items-center" href="https://www.linkedin.com/company/gamasutra/" rel="noreferrer" title="Linkedin" target="_target"><i class="text-white fab fa-linkedin-in"></i></a></div><div class="facebook-wrap sns-link"><a class="d-flex justify-content-center align-items-center" href="https://www.facebook.com/GamasutraOfficial/" rel="noreferrer" title="Facebook" target="_target"><i class="text-white fab fa-facebook-f"></i></a></div></div></div></div></div><div class="row connect-links py-4 mx-0"><div class="link-group col-12 col-md-4 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_blank" href="https://www.gamedeveloper.com/about-game-developer">About Us</a></div><div class="link-group col-12 col-md-4 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_blank" href="https://www.gamedeveloper.com/advertise-with-us">Advertise With Us</a></div><div class="link-group col-12 col-md-4 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_self" href="https://www.gamedeveloper.com/report-an-issue">Report An Issue</a></div></div><div class="row our-network-section mx-0"><div class="label">Our Network:</div><div class="networks w-100 d-flex"><div class="our-network-item"><a target="_blank" href="https://gdconf.com" title="GDC" class="d-flex align-items-center" rel="noreferrer"><img isnotlazyload="true" src="https://eu-images.contentstack.com/v3/assets/blt95b381df7c12c15d/blt64f777be7073c715/6126883beb5e7a021d3cf779/GDC_logo_k.png" alt="GDC Logo" width="auto" height="32"/><span class="d-none">https://eu-images.contentstack.com/v3/assets/blt95b381df7c12c15d/blt64f777be7073c715/6126883beb5e7a021d3cf779/GDC_logo_k.png</span></a></div><div class="our-network-item"><a target="_blank" href="https://www.gdcvault.com" title="GDC Vault" class="d-flex align-items-center" rel="noreferrer"><img isnotlazyload="true" src="https://eu-images.contentstack.com/v3/assets/blt95b381df7c12c15d/blte556a65784279a9b/61268827eb5e7a021d3cf775/masthead_logo.png" alt="GDC Vault Logo" width="auto" height="32"/><span class="d-none">https://eu-images.contentstack.com/v3/assets/blt95b381df7c12c15d/blte556a65784279a9b/61268827eb5e7a021d3cf775/masthead_logo.png</span></a></div></div></div></div></div></div></div><span class="search-icon"><svg width="15" height="15" fill="none" xmlns="http://www.w3.org/2000/svg" class="ml-2"><path d="M6.286.214a6.071 6.071 0 014.768 9.83l3.237 3.237a.714.714 0 01-1.01 1.01l-3.237-3.237A6.071 6.071 0 116.285.214zm0 1.429a4.643 4.643 0 100 9.286 4.643 4.643 0 000-9.286z" fill="#fff"></path></svg></span></div></nav></div></div><div class="row navigation-menu-mobile"><div class="w-100"><nav class="pr-0 pl-0 pb-0 navbar navbar-expand navbar-light"><div class="d-flex category-list w-100 navbar-nav"><div class="menu-item feature-link d-flex align-items-center"><span class="nav-link d-flex pr-3 align-items-center ml-0"><a href="https://jobs.gamasutra.com" class="nav-link" title="Jobs">Jobs</a></span></div><div class="menu-item topics d-flex align-items-center"><span class="nav-link d-flex pr-3 align-items-center justify-content-between" title="Sections">Sections</span><div class="expand-menu" style="display:none"><div class="container px-0"><div class="row head justify-content-between align-items-center mx-0"><span class="close-button">Close<svg width="10" height="10" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M9 1L1 9m8 0L1 1" stroke="#0B0B0B" stroke-width="2" stroke-miterlimit="10" stroke-linecap="round"></path></svg></span><div class="back-button"><svg width="14" height="14" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M6.999 1.445a5.556 5.556 0 110 11.11 5.556 5.556 0 010-11.11zM13.665 7A6.667 6.667 0 10.331 7a6.667 6.667 0 0013.334 0zm-4.444.556a.556.556 0 000-1.111H6.118l.718-.719a.556.556 0 00-.786-.785L4.384 6.608a.556.556 0 000 .785L6.05 9.06a.556.556 0 00.786-.786l-.718-.718H9.22z" fill="#212324"></path></svg>Back</div><div class="menu-title">Sections</div></div><div class="row casual-links mx-0"><div class="topic-group"><a href="https://www.gamedeveloper.com/disciplines" class="nav-link primary" title="Disciplines">Disciplines</a><div class="secondary-topic-group"><a title="Programming" class="nav-link secondary" href="https://www.gamedeveloper.com/programming">Programming</a><a title="Design" class="nav-link secondary" href="https://www.gamedeveloper.com/design">Design</a><a title="Audio" class="nav-link secondary" href="https://www.gamedeveloper.com/audio">Audio</a><a title="Art" class="nav-link secondary" href="https://www.gamedeveloper.com/art">Art</a><a title="Production" class="nav-link secondary" href="https://www.gamedeveloper.com/production">Production</a><a title="Business" class="nav-link secondary" href="https://www.gamedeveloper.com/business">Business</a></div><div class="icon-container for-mobile"><svg width="14" height="13" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-up" style="display:none"><path fill-rule="evenodd" clip-rule="evenodd" d="M.448 7C.448 3.324 3.416.333 7.063.333 10.711.333 13.68 3.324 13.68 7a6.65 6.65 0 01-3.608 5.94.55.55 0 01-.742-.242.558.558 0 01.24-.747A5.542 5.542 0 0012.576 7c0-3.064-2.473-5.556-5.513-5.556S1.551 3.937 1.551 7a5.542 5.542 0 003.007 4.95c.27.14.378.474.24.747a.549.549 0 01-.742.242A6.65 6.65 0 01.448 7zm9.205.436a.559.559 0 01.01.785.549.549 0 01-.78.01L7.068 6.45 5.243 8.232a.548.548 0 01-.78-.01.559.559 0 01.01-.786L6.29 5.654a1.098 1.098 0 011.554.005l1.81 1.777z" fill="#000"></path></svg><svg width="14" height="13" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-down" style="display:block"><path fill-rule="evenodd" clip-rule="evenodd" d="M13.668 6A6.675 6.675 0 017 12.667 6.675 6.675 0 01.334 6 6.644 6.644 0 013.97.06a.555.555 0 11.506.99A5.537 5.537 0 001.446 6 5.562 5.562 0 007 11.554 5.562 5.562 0 0012.557 6a5.537 5.537 0 00-3.03-4.95.556.556 0 01.505-.989A6.644 6.644 0 0113.668 6zM4.39 5.564a.556.556 0 11.776-.796l1.83 1.782 1.839-1.782a.556.556 0 11.775.796l-1.83 1.782a1.111 1.111 0 01-1.566-.005L4.391 5.564z" fill="#000"></path></svg></div><div class="secondary-topic-group for-mobile" style="display:none"><a title="Programming" class="nav-link secondary" href="https://www.gamedeveloper.com/programming">Programming</a><a title="Design" class="nav-link secondary" href="https://www.gamedeveloper.com/design">Design</a><a title="Audio" class="nav-link secondary" href="https://www.gamedeveloper.com/audio">Audio</a><a title="Art" class="nav-link secondary" href="https://www.gamedeveloper.com/art">Art</a><a title="Production" class="nav-link secondary" href="https://www.gamedeveloper.com/production">Production</a><a title="Business" class="nav-link secondary" href="https://www.gamedeveloper.com/business">Business</a></div></div><div class="topic-group"><a href="https://www.gamedeveloper.com/topics" class="nav-link primary" title="Topics">Topics</a><div class="secondary-topic-group"><a title="Console" class="nav-link secondary" href="https://www.gamedeveloper.com/console">Console</a><a title="PC" class="nav-link secondary" href="https://www.gamedeveloper.com/pc">PC</a><a title="Mobile" class="nav-link secondary" href="https://www.gamedeveloper.com/mobile">Mobile</a><a title="Extended Reality" class="nav-link secondary" href="https://www.gamedeveloper.com/extended-reality">Extended Reality</a><a title="The Cloud" class="nav-link secondary" href="https://www.gamedeveloper.com/the-cloud">The Cloud</a><a title="Culture" class="nav-link secondary" href="https://www.gamedeveloper.com/culture">Culture</a></div><div class="icon-container for-mobile"><svg width="14" height="13" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-up" style="display:none"><path fill-rule="evenodd" clip-rule="evenodd" d="M.448 7C.448 3.324 3.416.333 7.063.333 10.711.333 13.68 3.324 13.68 7a6.65 6.65 0 01-3.608 5.94.55.55 0 01-.742-.242.558.558 0 01.24-.747A5.542 5.542 0 0012.576 7c0-3.064-2.473-5.556-5.513-5.556S1.551 3.937 1.551 7a5.542 5.542 0 003.007 4.95c.27.14.378.474.24.747a.549.549 0 01-.742.242A6.65 6.65 0 01.448 7zm9.205.436a.559.559 0 01.01.785.549.549 0 01-.78.01L7.068 6.45 5.243 8.232a.548.548 0 01-.78-.01.559.559 0 01.01-.786L6.29 5.654a1.098 1.098 0 011.554.005l1.81 1.777z" fill="#000"></path></svg><svg width="14" height="13" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon-dropdown icon-down" style="display:block"><path fill-rule="evenodd" clip-rule="evenodd" d="M13.668 6A6.675 6.675 0 017 12.667 6.675 6.675 0 01.334 6 6.644 6.644 0 013.97.06a.555.555 0 11.506.99A5.537 5.537 0 001.446 6 5.562 5.562 0 007 11.554 5.562 5.562 0 0012.557 6a5.537 5.537 0 00-3.03-4.95.556.556 0 01.505-.989A6.644 6.644 0 0113.668 6zM4.39 5.564a.556.556 0 11.776-.796l1.83 1.782 1.839-1.782a.556.556 0 11.775.796l-1.83 1.782a1.111 1.111 0 01-1.566-.005L4.391 5.564z" fill="#000"></path></svg></div><div class="secondary-topic-group for-mobile" style="display:none"><a title="Console" class="nav-link secondary" href="https://www.gamedeveloper.com/console">Console</a><a title="PC" class="nav-link secondary" href="https://www.gamedeveloper.com/pc">PC</a><a title="Mobile" class="nav-link secondary" href="https://www.gamedeveloper.com/mobile">Mobile</a><a title="Extended Reality" class="nav-link secondary" href="https://www.gamedeveloper.com/extended-reality">Extended Reality</a><a title="The Cloud" class="nav-link secondary" href="https://www.gamedeveloper.com/the-cloud">The Cloud</a><a title="Culture" class="nav-link secondary" href="https://www.gamedeveloper.com/culture">Culture</a></div></div></div><div class="row promoted-links mx-0"><div class="topic-group"><a href="https://www.gamedeveloper.com/latest/news" class="nav-link promoted" title="[News]">[News]</a></div><div class="topic-group"><a href="https://www.gamedeveloper.com/latest/features" class="nav-link promoted" title="[Features]">[Features]</a></div><div class="topic-group"><a href="https://www.gamedeveloper.com/latest/developer-insights" class="nav-link promoted" title="[Developer Insights]">[Developer Insights]</a></div><div class="topic-group"><a href="https://gamasutra.com/pressreleases_index.php" class="nav-link promoted" title="[Press Releases] &gt;">[Press Releases] &gt;</a></div><div class="topic-group"><a href="https://www.gamecareerguide.com/" class="nav-link promoted" title="[Game Career Guide] &gt;">[Game Career Guide] &gt;</a></div></div></div></div></div><div class="menu-item reports d-flex align-items-center"><span class="nav-link d-flex pr-3 align-items-center justify-content-between" title="Blogs">Blogs</span><div class="expand-menu" style="display:none"><div class="container px-0"><div class="row head justify-content-between align-items-center mx-0"><span class="close-button">Close<svg width="10" height="10" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M9 1L1 9m8 0L1 1" stroke="#0B0B0B" stroke-width="2" stroke-miterlimit="10" stroke-linecap="round"></path></svg></span><div class="back-button"><svg width="14" height="14" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M6.999 1.445a5.556 5.556 0 110 11.11 5.556 5.556 0 010-11.11zM13.665 7A6.667 6.667 0 10.331 7a6.667 6.667 0 0013.334 0zm-4.444.556a.556.556 0 000-1.111H6.118l.718-.719a.556.556 0 00-.786-.785L4.384 6.608a.556.556 0 000 .785L6.05 9.06a.556.556 0 00.786-.786l-.718-.718H9.22z" fill="#212324"></path></svg>Back</div><div class="menu-title">Blogs</div></div><div class="row report-links py-4 mx-0"><div class="link-group col-12 col-md-3 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_blank" href="https://www.gamedeveloper.com/blogs">[All Blogs]</a></div><div class="link-group col-12 col-md-3 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_blank" href="https://www.gamasutra.com/static2/blogsubmissions.html">Write for Game Developer</a></div><div class="link-group col-12 col-md-3 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_blank" href="https://gamasutra.com/blogs/edit/blog/item/">Blog Now</a></div></div></div></div></div><div class="menu-item connect d-flex align-items-center"><span class="nav-link d-flex pr-3 align-items-center justify-content-between" title="Connect">Connect</span><div class="expand-menu" style="display:none"><div class="container px-0"><div class="row head justify-content-between align-items-center mx-0"><span class="close-button">Close<svg width="10" height="10" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M9 1L1 9m8 0L1 1" stroke="#0B0B0B" stroke-width="2" stroke-miterlimit="10" stroke-linecap="round"></path></svg></span><div class="back-button"><svg width="14" height="14" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M6.999 1.445a5.556 5.556 0 110 11.11 5.556 5.556 0 010-11.11zM13.665 7A6.667 6.667 0 10.331 7a6.667 6.667 0 0013.334 0zm-4.444.556a.556.556 0 000-1.111H6.118l.718-.719a.556.556 0 00-.786-.785L4.384 6.608a.556.556 0 000 .785L6.05 9.06a.556.556 0 00.786-.786l-.718-.718H9.22z" fill="#212324"></path></svg>Back</div><div class="menu-title">Connect</div></div><div class="row brand-engagement-section mx-0"><div class="brand-engagement-module d-flex flex-row flex-wrap"><div class="module-item"><div class="module-item-eyebrow">Register for a</div><div class="module-item-title">Game Developer Account</div><div class="module-item-description"><div><p>Gain full access to resources (events, white paper, webinars, reports, etc)<br>Single sign-on to all Informa products</p>

</div></div><div class="module-item-button"><a class="dr-btn text-decoration-none text-white" target="_blank" href="https://www.gamasutra.com/php-bin/sso/join.php" rel="noreferrer">Register</a></div></div><div class="module-item"><div class="module-item-eyebrow">Subscribe to</div><div class="module-item-title">Game Developer Newsletter</div><div class="module-item-description"><div>
<p>Get daily Game Developer top stories every morning straight into your inbox</p>
</div></div><div class="module-item-button"><a class="dr-btn text-decoration-none text-white" target="_blank" href="https://www.gamasutra.com/newsletter-signup" rel="noreferrer">Subscribe</a></div></div><div class="module-item"><div class="module-item-eyebrow">Follow us</div><div class="module-item-title">@gamedevdotcom</div><div class="module-item-description"><div>
<p>Follow us @gamedevdotcom to stay up-to-date with the latest news & insider information about events & more</p>
</div></div><div class="sns-container d-flex"><div class="rss-wrap sns-link"><a class="d-flex justify-content-center align-items-center" href="https://www.gamedeveloper.com/rss.xml" rel="noreferrer" title="RSS" target="_target"><i class="text-white fas fa-rss"></i></a></div><div class="twitter-wrap sns-link"><a class="d-flex justify-content-center align-items-center" href="https://twitter.com/gamedevdotcom" rel="noreferrer" title="Twitter" target="_target"><i class="text-white fab fa-twitter"></i></a></div><div class="linkedin-wrap sns-link"><a class="d-flex justify-content-center align-items-center" href="https://www.linkedin.com/company/gamasutra/" rel="noreferrer" title="Linkedin" target="_target"><i class="text-white fab fa-linkedin-in"></i></a></div><div class="facebook-wrap sns-link"><a class="d-flex justify-content-center align-items-center" href="https://www.facebook.com/GamasutraOfficial/" rel="noreferrer" title="Facebook" target="_target"><i class="text-white fab fa-facebook-f"></i></a></div></div></div></div></div><div class="row connect-links py-4 mx-0"><div class="link-group col-12 col-md-4 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_blank" href="https://www.gamedeveloper.com/about-game-developer">About Us</a></div><div class="link-group col-12 col-md-4 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_blank" href="https://www.gamedeveloper.com/advertise-with-us">Advertise With Us</a></div><div class="link-group col-12 col-md-4 my-2 p-0"><a rel="noreferrer" class="nav-link font-weight-bold" target="_self" href="https://www.gamedeveloper.com/report-an-issue">Report An Issue</a></div></div><div class="row our-network-section mx-0"><div class="label">Our Network:</div><div class="networks w-100 d-flex"><div class="our-network-item"><a target="_blank" href="https://gdconf.com" title="GDC" class="d-flex align-items-center" rel="noreferrer"><img isnotlazyload="true" src="https://eu-images.contentstack.com/v3/assets/blt95b381df7c12c15d/blt64f777be7073c715/6126883beb5e7a021d3cf779/GDC_logo_k.png" alt="GDC Logo" width="auto" height="32"/><span class="d-none">https://eu-images.contentstack.com/v3/assets/blt95b381df7c12c15d/blt64f777be7073c715/6126883beb5e7a021d3cf779/GDC_logo_k.png</span></a></div><div class="our-network-item"><a target="_blank" href="https://www.gdcvault.com" title="GDC Vault" class="d-flex align-items-center" rel="noreferrer"><img isnotlazyload="true" src="https://eu-images.contentstack.com/v3/assets/blt95b381df7c12c15d/blte556a65784279a9b/61268827eb5e7a021d3cf775/masthead_logo.png" alt="GDC Vault Logo" width="auto" height="32"/><span class="d-none">https://eu-images.contentstack.com/v3/assets/blt95b381df7c12c15d/blte556a65784279a9b/61268827eb5e7a021d3cf775/masthead_logo.png</span></a></div></div></div></div></div></div></div></nav></div><hr/><div class="w-100 d-flex justify-content-between align-items-center"><a class="newsletter-sign-up iw-btn text-decoration-none" href="https://www.gamasutra.com/newsletter-signup" target="_blank" rel="noreferrer">Subscribe</a><div class="h-100 d-flex align-items-center mr-4"><div class="cursor-pointer login-text">Login</div><div class="text-white">/</div><div class="cursor-pointer login-text">Register</div></div></div></div></div></div><div class="search-bar-container" style="display:none"><div class="search-bar-background"></div><div class="container"><div class="search-bar-wrapper"><div class="search-box"><input type="text" class="search-input w-100" placeholder="Search Game Developer content"/><div class="btn search-btn"><svg width="15" height="15" fill="none" xmlns="http://www.w3.org/2000/svg" class="icon"><path d="M6.286.214a6.071 6.071 0 014.768 9.83l3.237 3.237a.714.714 0 01-1.01 1.01l-3.237-3.237A6.071 6.071 0 116.285.214zm0 1.429a4.643 4.643 0 100 9.286 4.643 4.643 0 000-9.286z" fill="#fff"></path></svg><span class="text">SEARCH</span></div></div><div class="search-message d-none">A minimum of 3 characters are required to be typed in the search bar in order to perform a search.</div></div></div></div><div class="black-background"></div><div class="black-background-for-mobile"></div></div><div class="header-wrap"></div></div><div id="wl_flogop_div" class="d-none"></div><div class="announcement initial closed"><div class="container"><div class="row"><div class="col-12 col-md-7 content-wrapper"><div class="toggle"><div class="toggle-icon-wrapper"><svg width="14" height="14" fill="none" xmlns="http://www.w3.org/2000/svg" class="bell-icon" style="display:block"><path d="M12.557 6.379a.556.556 0 01-.555-.556 5.796 5.796 0 00-1.709-4.125.556.556 0 01.786-.785 6.898 6.898 0 012.034 4.91.555.555 0 01-.556.556zM1.446 6.379a.556.556 0 01-.555-.556c0-1.855.722-3.599 2.034-4.91a.555.555 0 01.785.785 5.795 5.795 0 00-1.708 4.125.556.556 0 01-.556.556zM12.212 9.73a3.722 3.722 0 01-1.321-2.848V5.333A3.892 3.892 0 007.557 1.49v-.6a.556.556 0 10-1.11 0v.6a3.892 3.892 0 00-3.334 3.844v1.55a3.725 3.725 0 01-1.327 2.85.973.973 0 00.632 1.711h9.167a.973.973 0 00.627-1.715zM7.002 13.667A2.086 2.086 0 009.042 12H4.962A2.087 2.087 0 007 13.667z" fill="#fff"></path></svg><svg width="6" height="12" fill="none" xmlns="http://www.w3.org/2000/svg" class="arrow-icon" style="display:none"><path d="M5.67 6.003a.801.801 0 01-.193.528l-4.023 4.586a.6.6 0 01-.926 0 .823.823 0 010-1.056l3.56-4.058-3.56-4.059a.823.823 0 010-1.056.6.6 0 01.927 0l4.023 4.587a.801.801 0 01.191.528z" fill="#fff"></path></svg></div></div><div class="announcement-title">Announcements</div><div class="carousel slide"><ol class="carousel-indicators"><li class="active"></li><li></li></ol><div class="carousel-inner"><div interval="5000" class="active carousel-item"><div class="d-flex align-items-center carousel-caption"><div class="announcement-item-type d-flex align-items-center mr-3"><a class="cursor-pointer" target="_blank" href="https://www.gamedeveloper.com/report-an-issue" title="Click To Report An Issue" rel="noreferrer">Alert</a></div><div class="scroll-left text-white announcement-item-content flex-grow-1 d-flex align-items-center"><a class="cursor-pointer text-white" target="_blank" href="https://www.gamedeveloper.com/report-an-issue" title="Click To Report An Issue" rel="noreferrer">We are currently working to fix issues with cut-off articles and incorrect URLs. Click here to report an issue.</a></div></div></div><div interval="5000" class="carousel-item"><div class="d-flex align-items-center carousel-caption"><div class="announcement-item-type d-flex align-items-center mr-3"><a class="cursor-pointer" target="_self" href="https://www.gamedeveloper.com/culture/from-the-eic-welcome-to-game-developer-" title="From the EiC: Welcome to Game Developer!" rel="noreferrer">News</a></div><div class="scroll-left text-white announcement-item-content flex-grow-1 d-flex align-items-center"><a class="cursor-pointer text-white" target="_self" href="https://www.gamedeveloper.com/culture/from-the-eic-welcome-to-game-developer-" title="From the EiC: Welcome to Game Developer!" rel="noreferrer">Gamasutra is now Game Developer! Click here to learn more about the change, what&#x27;s new on the website, and what&#x27;s next!</a></div></div></div></div><a class="carousel-control-prev" role="button" href="#"><span aria-hidden="true" class="carousel-control-prev-icon"></span><span class="sr-only">Previous</span></a><a class="carousel-control-next" role="button" href="#"><span aria-hidden="true" class="carousel-control-next-icon"></span><span class="sr-only">Next</span></a></div></div></div></div></div><div class="container bg-white  pb-4 pt-4"><div class="d-flex w-100 justify-content-center"><div class="informa-dfp-ads" data-size="970*90,728*90,300*50,320*50,970*250" data-name="leaderBoard_728_1v" data-targeting="pos=728_1v" data-mapping="1119*0=970*90,970*250,728*90|728*0=728*90|0*0=320*50,300*50"></div></div></div><main><script>
                window.adsPattern = 'article/disciplines/production';
                window.pageId = 'blt507ce9721e540315';
                window.aid = '620336';
                window.ptype = 'article';
              </script><script type="application/ld+json">{"@context":"https://schema.org","@type":"NewsArticle","image":["https://eu-images.contentstack.com/v3/assets/blt95b381df7c12c15d/blt2fa90bdba23507fc/6168173779367711c6e90962/Rico_Anti_Cheat.png"],"headline":"Activision has created a kernel-level anti-cheat system for <I>Call of Duty</I>","datePublished":"2021-10-14T11:29:22.000Z","dateModified":"2021-10-14T14:10:41.846Z","articleBody":"Activision has developed a new anti-cheat system called Ricochet to help&nbsp;level the playing field&nbsp;in Call of Duty.  The publisher described Ricochet as a \"multi-faceted\" system that incorporates server-side tools capable of&nbsp;monitoring analytics to identify cheating, enhanced investigation processes, updates that fortify player accounts, and additional backend security measures. Ricochet will also utilize a new PC kernel-level driver developed internally for the Call of Duty franchise. Activision said the driver will help it rumble cheaters to reinforce and strengthen its overall server security. \"Kernel-level drivers are given a high level of access to monitor and manage software and applications on a PC, such as your PC's graphics card driver,\" explained Activision. \"The driver element of the Ricochet Anti-Cheat system will check the software and applications that attempt to interact and manipulate Call of Duty: Warzone, providing the overall security team more data to bolster security. Once the kernel-level driver is deployed; it will be required to play Warzone.\" \"In its initial rollout on Call of Duty: Warzone, the kernel-level driver will only operate when you play on PC. The driver is not always-on. The software turns on when you start Call of Duty: Warzone and shuts down when you close the game.  Plus, the kernel-level driver only monitors and reports activity related to Call of Duty.\" Ricochet's backend anti-cheat measures will launch alongside Call of Duty: Vanguard, before being integrated into Warzone when the 'Pacific' update arrives later this year.  The kernel-level driver, meanwhile, will launch first in Warzone before being integrated into Vanguard at a later date. Those interested in learning more about Ricochet can read the full explainer on the Call of Duty blog.","author":{"@type":"Person","name":"Chris Kerr","url":"https://www.gamedeveloper.com/author/chris-kerr"}}</script><div class="page-container article-page bg-white single-column container"><div class="row"><div class="col-lg-12"><a href="https://www.gamedeveloper.com/latest/news" class="commentary-btn btn text-white">News</a><div class="heading"><h1 class="article-title">Activision has created a kernel-level anti-cheat system for <I>Call of Duty</I></h1><div class="summary"><div>The system, dubbed 'Ricochet,' will also incorporate server-side and backend tools.</div></div><div class="byline"><div class="author"><a href="/author/chris-kerr"><div class="lazyload-wrapper "><div style="height:50px" class="lazyload-placeholder"></div></div></a><div class="author-info"><div class="author-name"><a href="/author/chris-kerr">Chris Kerr</a></div><div class="author-role"><a class="author-role" href="/author/chris-kerr">News Editor</a></div></div></div><div class="timestamp">October 14, 2021</div></div></div><div class="featured-image"><div class="lazyload-wrapper "><div style="height:200px" class="lazyload-placeholder"></div></div><div class="image-caption"><span></span></div></div><div class="sns-sharing"><button aria-label="twitter" class="react-share__ShareButton twitter sns-btn" style="background-color:transparent;border:none;padding:0;font:inherit;color:inherit;cursor:pointer"><svg viewBox="0 0 64 64" width="32" height="32"><rect width="64" height="64" rx="0" ry="0" fill="#00aced"></rect><path d="M48,22.1c-1.2,0.5-2.4,0.9-3.8,1c1.4-0.8,2.4-2.1,2.9-3.6c-1.3,0.8-2.7,1.3-4.2,1.6 C41.7,19.8,40,19,38.2,19c-3.6,0-6.6,2.9-6.6,6.6c0,0.5,0.1,1,0.2,1.5c-5.5-0.3-10.3-2.9-13.5-6.9c-0.6,1-0.9,2.1-0.9,3.3 c0,2.3,1.2,4.3,2.9,5.5c-1.1,0-2.1-0.3-3-0.8c0,0,0,0.1,0,0.1c0,3.2,2.3,5.8,5.3,6.4c-0.6,0.1-1.1,0.2-1.7,0.2c-0.4,0-0.8,0-1.2-0.1 c0.8,2.6,3.3,4.5,6.1,4.6c-2.2,1.8-5.1,2.8-8.2,2.8c-0.5,0-1.1,0-1.6-0.1c2.9,1.9,6.4,2.9,10.1,2.9c12.1,0,18.7-10,18.7-18.7 c0-0.3,0-0.6,0-0.8C46,24.5,47.1,23.4,48,22.1z" fill="white"></path></svg></button><button aria-label="linkedin" class="react-share__ShareButton linkedin sns-btn" style="background-color:transparent;border:none;padding:0;font:inherit;color:inherit;cursor:pointer"><svg viewBox="0 0 64 64" width="32" height="32"><rect width="64" height="64" rx="0" ry="0" fill="#007fb1"></rect><path d="M20.4,44h5.4V26.6h-5.4V44z M23.1,18c-1.7,0-3.1,1.4-3.1,3.1c0,1.7,1.4,3.1,3.1,3.1 c1.7,0,3.1-1.4,3.1-3.1C26.2,19.4,24.8,18,23.1,18z M39.5,26.2c-2.6,0-4.4,1.4-5.1,2.8h-0.1v-2.4h-5.2V44h5.4v-8.6 c0-2.3,0.4-4.5,3.2-4.5c2.8,0,2.8,2.6,2.8,4.6V44H46v-9.5C46,29.8,45,26.2,39.5,26.2z" fill="white"></path></svg></button><button aria-label="facebook" class="react-share__ShareButton fb sns-btn" style="background-color:transparent;border:none;padding:0;font:inherit;color:inherit;cursor:pointer"><svg viewBox="0 0 64 64" width="32" height="32"><rect width="64" height="64" rx="0" ry="0" fill="#3b5998"></rect><path d="M34.1,47V33.3h4.6l0.7-5.3h-5.3v-3.4c0-1.5,0.4-2.6,2.6-2.6l2.8,0v-4.8c-0.5-0.1-2.2-0.2-4.1-0.2 c-4.1,0-6.9,2.5-6.9,7V28H24v5.3h4.6V47H34.1z" fill="white"></path></svg></button><button aria-label="reddit" class="react-share__ShareButton reddit sns-btn" style="background-color:transparent;border:none;padding:0;font:inherit;color:inherit;cursor:pointer"><svg viewBox="0 0 64 64" width="32" height="32"><rect width="64" height="64" rx="0" ry="0" fill="#ff4500"></rect><path d="m 52.8165,31.942362 c 0,-2.4803 -2.0264,-4.4965 -4.5169,-4.4965 -1.2155,0 -2.3171,0.4862 -3.128,1.2682 -3.077,-2.0247 -7.2403,-3.3133 -11.8507,-3.4782 l 2.5211,-7.9373 6.8272,1.5997 -0.0102,0.0986 c 0,2.0281 1.6575,3.6771 3.6958,3.6771 2.0366,0 3.6924,-1.649 3.6924,-3.6771 0,-2.0281 -1.6575,-3.6788 -3.6924,-3.6788 -1.564,0 -2.8968,0.9758 -3.4357,2.3443 l -7.3593,-1.7255 c -0.3213,-0.0782 -0.6477,0.1071 -0.748,0.4233 L 32,25.212062 c -4.8246,0.0578 -9.1953,1.3566 -12.41,3.4425 -0.8058,-0.7446 -1.8751,-1.2104 -3.0583,-1.2104 -2.4905,0 -4.5152,2.0179 -4.5152,4.4982 0,1.649 0.9061,3.0787 2.2389,3.8607 -0.0884,0.4794 -0.1462,0.9639 -0.1462,1.4569 0,6.6487 8.1736,12.0581 18.2223,12.0581 10.0487,0 18.224,-5.4094 18.224,-12.0581 0,-0.4658 -0.0493,-0.9248 -0.1275,-1.377 1.4144,-0.7599 2.3885,-2.2304 2.3885,-3.9406 z m -29.2808,3.0872 c 0,-1.4756 1.207,-2.6775 2.6894,-2.6775 1.4824,0 2.6877,1.2019 2.6877,2.6775 0,1.4756 -1.2053,2.6758 -2.6877,2.6758 -1.4824,0 -2.6894,-1.2002 -2.6894,-2.6758 z m 15.4037,7.9373 c -1.3549,1.3481 -3.4816,2.0043 -6.5008,2.0043 l -0.0221,-0.0051 -0.0221,0.0051 c -3.0209,0 -5.1476,-0.6562 -6.5008,-2.0043 -0.2465,-0.2448 -0.2465,-0.6443 0,-0.8891 0.2465,-0.2465 0.6477,-0.2465 0.8942,0 1.105,1.0999 2.9393,1.6337 5.6066,1.6337 l 0.0221,0.0051 0.0221,-0.0051 c 2.6673,0 4.5016,-0.5355 5.6066,-1.6354 0.2465,-0.2465 0.6477,-0.2448 0.8942,0 0.2465,0.2465 0.2465,0.6443 0,0.8908 z m -0.3213,-5.2615 c -1.4824,0 -2.6877,-1.2002 -2.6877,-2.6758 0,-1.4756 1.2053,-2.6775 2.6877,-2.6775 1.4824,0 2.6877,1.2019 2.6877,2.6775 0,1.4756 -1.2053,2.6758 -2.6877,2.6758 z" fill="white"></path></svg></button><button type="button" class="pdf sns-btn btn btn-primary">PDF</button><button aria-label="email" class="react-share__ShareButton email sns-btn" style="background-color:transparent;border:none;padding:0;font:inherit;color:inherit;cursor:pointer"><svg viewBox="0 0 64 64" width="32" height="32"><rect width="64" height="64" rx="0" ry="0" fill="#7f7f7f"></rect><path d="M17,22v20h30V22H17z M41.1,25L32,32.1L22.9,25H41.1z M20,39V26.6l12,9.3l12-9.3V39H20z" fill="white"></path></svg></button></div><div class="article-content "><div class="informa-dfp-ads" data-name="Article Video Ad - video_v" data-size="1*1" data-targeting="pos=video_v"></div><div><p>Activision has developed a new anti-cheat system called Ricochet to help&nbsp;level the playing field&nbsp;in <em>Call of Duty</em>. </p><div class="rectangle-ads">
      <div
        class="informa-dfp-ads"
        data-name="Rectangle_300_1v_article"
        data-size="300*250,300*600"
        data-targeting="pos=300_1v_article"
      ></div>
    </div>

<p>The publisher described Ricochet as a "multi-faceted" system that incorporates server-side tools capable of&nbsp;monitoring analytics to identify cheating, enhanced investigation processes, updates that fortify player accounts, and additional backend security measures.</p>

<p>Ricochet will also utilize a new PC kernel-level driver developed internally for the <em>Call of Duty </em>franchise. Activision said the driver will help it rumble cheaters to reinforce and strengthen its overall server security.</p>

<p>"Kernel-level drivers are given a high level of access to monitor and manage software and applications on a PC, such as your PC's graphics card driver," explained Activision. "The driver element of the Ricochet Anti-Cheat system will check the software and applications that attempt to interact and manipulate <em>Call of Duty: Warzone</em>, providing the overall security team more data to bolster security. Once the kernel-level driver is deployed; it will be required to play <em>Warzone</em>."</p>

<p>"In its initial rollout on <em>Call of Duty: Warzone</em>, the kernel-level driver will only operate when you play on PC. The driver is not always-on. The software turns on when you start <em>Call of Duty: Warzone</em> and shuts down when you close the game.  Plus, the kernel-level driver only monitors and reports activity related to <em>Call of Duty</em>."</p>

<p>Ricochet's backend anti-cheat measures will launch alongside <em>Call of Duty: Vanguard</em>, before being integrated into <em>Warzone</em> when the 'Pacific' update arrives later this year. </p>

<p>The kernel-level driver, meanwhile, will launch first in <em>Warzone</em> before being integrated into <em>Vanguard </em>at a later date. Those interested in learning more about Ricochet can <a href="https://www.callofduty.com/blog/2021/10/ricochet-anti-cheat-initiative-for-call-of-duty">read the full explainer on the Call of Duty blog</a>.<br></p><div class="mb-3">
      <div
        class="informa-dfp-ads"
        data-name="Native_Ad_native_2v"
        data-size="fluid"
        data-targeting="pos=native_2v"
      ></div>
    </div></div></div><div class="newsletter-cta w-100 mt-3"><div class="text">Get daily news, dev blogs, and stories from Game Developer straight to your inbox</div><a class="subscribe-btn dr-btn" href="https://www.gamasutra.com/newsletter-signup" title="Subscribe" target="_blank" rel="noreferrer">Subscribe</a></div><div class="bibblio_includes_beacon"></div><div class="bibblio_import_beacon" id="bibblio_catalogue_default"></div><div class="w-100 d-none d-lg-block"></div><div class="w-100 d-lg-block"><div class="informa-dfp-ads" data-name="Native_Ad_insight_1v" data-size="fluid" data-targeting="pos=nativeinsight_1v"></div></div></div></div></div><div class="wrap-list-modules" style="width:100%"><div class="module-block container" id="bltac1e647f023f6193"><div class="module-job-wrap"><h3 class="m-job-title">Latest Jobs</h3><div class="jobs-list row"><div class="job-item col-lg-3 col-md-6 col-xs-12"><div class="job-container"><div><div class="job-logo d-none d-lg-block d-xl-block"><div class="lazyload-wrapper "><div style="height:180px" class="lazyload-placeholder"></div></div></div><div class="job-logo d-none d-md-block d-lg-none d-xl-none"><div class="lazyload-wrapper "><div style="height:220px" class="lazyload-placeholder"></div></div></div><div class="job-logo d-md-none"><div class="lazyload-wrapper "><div style="height:220px" class="lazyload-placeholder"></div></div></div></div><div class="job-des"><h4 class="job-company-name">Sucker Punch Productions</h4><div class="job-location">Bellevue, Washington</div><div class="job-date">08.27.21</div></div><a class="job-title" href="https://jobs.gamasutra.com/job/combat-designer-bellevue-washington-35221">Combat Designer</a></div></div><div class="job-item col-lg-3 col-md-6 col-xs-12"><div class="job-container"><div><div class="job-logo d-none d-lg-block d-xl-block"><div class="lazyload-wrapper "><div style="height:180px" class="lazyload-placeholder"></div></div></div><div class="job-logo d-none d-md-block d-lg-none d-xl-none"><div class="lazyload-wrapper "><div style="height:220px" class="lazyload-placeholder"></div></div></div><div class="job-logo d-md-none"><div class="lazyload-wrapper "><div style="height:220px" class="lazyload-placeholder"></div></div></div></div><div class="job-des"><h4 class="job-company-name">Xbox Graphics</h4><div class="job-location">Redmond, Washington</div><div class="job-date">08.27.21</div></div><a class="job-title" href="https://jobs.gamasutra.com/job/senior-software-engineer-gpu-compilers-redmond-washington-35124">Senior Software Engineer: GPU Compilers</a></div></div><div class="job-item col-lg-3 col-md-6 col-xs-12"><div class="job-container"><div><div class="job-logo d-none d-lg-block d-xl-block"><div class="lazyload-wrapper "><div style="height:180px" class="lazyload-placeholder"></div></div></div><div class="job-logo d-none d-md-block d-lg-none d-xl-none"><div class="lazyload-wrapper "><div style="height:220px" class="lazyload-placeholder"></div></div></div><div class="job-logo d-md-none"><div class="lazyload-wrapper "><div style="height:220px" class="lazyload-placeholder"></div></div></div></div><div class="job-des"><h4 class="job-company-name">Insomniac Games</h4><div class="job-location">Burbank, California</div><div class="job-date">08.27.21</div></div><a class="job-title" href="https://jobs.gamasutra.com/job/systems-designer-burbank-california-35149">Systems Designer</a></div></div><div class="job-item col-lg-3 col-md-6 col-xs-12"><div class="job-container"><div><div class="job-logo d-none d-lg-block d-xl-block"><div class="lazyload-wrapper "><div style="height:180px" class="lazyload-placeholder"></div></div></div><div class="job-logo d-none d-md-block d-lg-none d-xl-none"><div class="lazyload-wrapper "><div style="height:220px" class="lazyload-placeholder"></div></div></div><div class="job-logo d-md-none"><div class="lazyload-wrapper "><div style="height:220px" class="lazyload-placeholder"></div></div></div></div><div class="job-des"><h4 class="job-company-name">Deep Silver Volition</h4><div class="job-location">Champaign, Illinois</div><div class="job-date">08.27.21</div></div><a class="job-title" href="https://jobs.gamasutra.com/job/senior-environment-artist-champaign-illinois-35197">Senior Environment Artist</a></div></div></div><a class="m-job-link" href="https://jobs.gamasutra.com/index" target="_self">More Jobs<!-- -->   <svg width="20" height="20" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M10 18.333a8.333 8.333 0 110-16.666 8.333 8.333 0 110 16.666zM0 10c0 5.523 4.478 10 10 10 5.523 0 10-4.477 10-10 0-5.522-4.477-10-10-10C4.478 0 0 4.478 0 10zm6.667-.833a.833.833 0 100 1.666h4.655l-1.078 1.078a.833.833 0 001.178 1.178l2.5-2.5a.834.834 0 000-1.178l-2.5-2.5a.833.833 0 00-1.178 1.178l1.078 1.078H6.667z" fill="#E60012"></path></svg></a></div> </div></div><div class="wrap-list-modules" style="width:100%"><div class="module-block container" id="bltfa7a2b95449c0aa3"><div id="module-brand-engagement"><div class="row"><div class="col-md-12"><h4 class="be-module-title">CONNECT WITH US</h4></div></div><div class="large-screen"><div class="row small-title"><div class="col-md-4 be-section"><h5 class="be-sub-title">Register for a</h5></div><div class="col-md-4 be-section"><h5 class="be-sub-title">Subscribe to</h5></div><div class="col-md-4 be-section"><h5 class="be-sub-title">Follow us</h5></div></div><div class="row title"><div class="col-md-4 be-section"><h4 class="be-title">Game Developer Account</h4></div><div class="col-md-4 be-section"><h4 class="be-title">Game Developer Newsletter</h4></div><div class="col-md-4 be-section"><h4 class="be-title">@gamedevdotcom</h4></div></div></div><div class="row"><div class="col-md-4 be-section"><h5 class="be-sub-title show-mobile">Register for a</h5><h4 class="be-title show-mobile">Game Developer Account</h4><div class="be-des"><div><p>Gain full access to resources (events, white paper, webinars, reports, etc)<br>Single sign-on to all Informa products</p>

</div></div><a class="btn btn-be" href="https://www.gamasutra.com/php-bin/sso/join.php" target="_blank" rel="noreferrer">Register</a></div><div class="col-md-4 be-section"><h5 class="be-sub-title show-mobile">Subscribe to</h5><h4 class="be-title show-mobile">Game Developer Newsletter</h4><div class="be-des"><div>
<p>Get daily Game Developer top stories every morning straight into your inbox</p>
</div></div><a class="btn btn-be" href="https://www.gamasutra.com/newsletter-signup" target="_blank" rel="noreferrer">Subscribe</a></div><div class="col-md-4 be-section"><h5 class="be-sub-title show-mobile">Follow us</h5><h4 class="be-title show-mobile">@gamedevdotcom</h4><div class="be-des"><div>
<p>Follow us @gamedevdotcom to stay up-to-date with the latest news & insider information about events & more</p>
</div></div><footer><div class="f-social-networks be-social-network"><ul class="d-flex justify-content-lg-start w-100"><li class="rss-wrap social-icon-wrap"><a href="https://www.gamedeveloper.com/rss.xml" rel="noreferrer" target="_blank" class="d-flex justify-content-between align-items-center"><i class="fas fa-rss"></i></a></li><li class="twitter-wrap social-icon-wrap"><a href="https://twitter.com/gamedevdotcom" rel="noreferrer" target="_blank" class="d-flex justify-content-between align-items-center"><i class="fab fa-twitter"></i></a></li><li class="linkedin-wrap social-icon-wrap"><a href="https://www.linkedin.com/company/gamasutra/" rel="noreferrer" target="_blank" class="d-flex justify-content-between align-items-center"><i class="fab fa-linkedin-in"></i></a></li><li class="facebook-wrap social-icon-wrap"><a href="https://www.facebook.com/GamasutraOfficial/" rel="noreferrer" target="_blank" class="d-flex justify-content-between align-items-center"><i class="fab fa-facebook-f"></i></a></li></ul></div></footer></div></div></div> </div></div></main><footer><div class="container"><div class="row"><div class="col-lg-5"><h4 class="f-nav-title">Discover More From Informa Tech</h4><div class="nav-2-col"><ul class="nav-2-col-ul-left"><li><a href="https://www.gdconf.com/" rel="noreferrer" target="_blank">Game Developers Conference</a></li><li><a href="https://jobs.gamasutra.com/" rel="noreferrer" target="_blank">Game Developer Jobs</a></li><li><a href="https://www.gdcvault.com/" rel="noreferrer" target="_blank">GDC Vault</a></li><li><a href="https://www.gamecareerguide.com/" rel="noreferrer" target="_blank">Game Career Guide</a></li></ul><ul class="nav-2-col-ul-right"><li><a href="https://igf.com/" rel="noreferrer" target="_blank">Independent Games Festival</a></li><li><a href="https://www.gamechoiceawards.com/" rel="noreferrer" target="_blank">Game Developers Choice Awards</a></li><li><a href="https://www.omdia.com/" rel="noreferrer" target="_blank">Omdia</a></li></ul></div></div><div class="col-lg-3"><h4 class="f-nav-title">Working With Us</h4><ul class="nav-2-col-ul-left"><li><a href="https://www.gamedeveloper.com/contact-game-developer" rel="noreferrer" target="_blank">Contact Us</a></li><li><a href="https://www.gamedeveloper.com/about-game-developer" rel="noreferrer" target="_blank">About Us</a></li><li><a href="/advertise-with-us" rel="noreferrer" target="_blank">Advertise</a></li></ul></div><div class="col-lg-4"><h4 class="f-nav-title f-nav-social-networks text-lg-left">Follow Game Developer On Social</h4><div class="f-social-networks"><ul class="d-flex justify-content-lg-start w-100"><li class="social-icon-wrap"><a href="https://www.gamedeveloper.com/rss.xml" rel="noreferrer" target="_blank"><i class="fas fa-rss"></i></a></li><li class="social-icon-wrap"><a href="https://twitter.com/gamedevdotcom" rel="noreferrer" target="_blank"><i class="fab fa-twitter"></i></a></li><li class="social-icon-wrap"><a href="https://www.facebook.com/pages/Gamasutra/31610613408" rel="noreferrer" target="_blank"><i class="fab fa-facebook-f"></i></a></li></ul></div></div></div><div class="row"><div class="w-100"><div class="f-hr"></div></div></div><div class="row"><div class="col-md-12 b-f-wrap "><div class="f-logo-wrap d-flex justify-content-between align-items-center"><div class="f-logo"><div class="lazyload-wrapper "><div style="height:200px" class="lazyload-placeholder"></div></div></div><div class="f-h-nav"><ul class="nav-horizontal d-flex"><li><a href="https://tech.informa.com/" rel="noreferrer" target="_blank">Home</a></li><li><a href="https://tech.informa.com/cookie-policy" rel="noreferrer" target="_blank">Cookies</a></li><li><a href="https://tech.informa.com/privacy-policy" rel="noreferrer" target="_blank">Privacy</a></li><li><a href="https://tech.informa.com/terms-and-conditions" rel="noreferrer" target="_blank">Terms</a></li></ul></div></div></div></div><div class="row"><div class="w-100"><div class="f-hr"></div></div></div><div class="row"><div class="col-md-12 b-f-wrap"><div class="f-logo-wrap d-flex justify-content-between align-items-center"><div class="f-logo o-hidden d-none d-sm-block"><img src="https://eu-images.contentstack.com/v3/assets/blt95b381df7c12c15d/blt1c6536159879dc33/61222a95eb5e7a021d3ce88a/Game_Developer_G_Logo_WHITE.png" alt="Logo"/></div><div class="copyright-wrap"><p>Copyright © <!-- -->2021<!-- --> <!-- -->Informa PLC Informa UK Limited is a company registered in England and Wales with company number 1072954 whose registered office is 5 Howick Place, London, SW1P 1WG.</p></div></div></div></div></div></footer></div></div></div><script id="__NEXT_DATA__" type="application/json">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</script><script nomodule="" src="https://www.gamedeveloper.com/_next/static/chunks/polyfills-ed341876a5c019e509cd.js"></script><script src="https://www.gamedeveloper.com/_next/static/chunks/webpack-47bce83ba23872c700ce.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/chunks/framework.efe182f2d62be1d8151a.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/chunks/405cc4cae2d9cefca885a3d03486a84054bb08bb.57f55179cc1f11928509.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/chunks/85c6f8fb922b6017aaa86837ce5896a534f77b02.129bddf45142da3a0709.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/chunks/main-7712fa30b8b947729c3a.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/chunks/29107295.f607d0242cf52a473e6a.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/chunks/75fc9c18.8f193e2393b07d969f29.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/chunks/72ca276a49ee30555249b62eec69910dcf744519.8ea633e330984d910dfd.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/chunks/34ed02caea4d7fb2f7667818f991ac468d15d9e2.acd4d4313dd55c874d38.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/chunks/pages/_app-8c0258683d485206ea72.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/chunks/1d137d3c2b42d89e594dd08d6a7e9bce6953895a.970ec15ec64d310fceb6.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/chunks/bb0110fccfbf064cd16b56f4717ff6b330e5e6c1.19aa060e658c9969a1d3.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/chunks/2b04dd72bf30b22157c26b953ab44337c7dc546c.dcfd80b3b171fc95e123.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/chunks/1aa4fccfc0a9a1798e4f36db5eb709b29904984b.d501ff24a2ea33baa01b.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/chunks/49437bdb1112dc30b54d2e54bd767365ba8cb15b.eb16c826fa1a17164099.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/chunks/pages/%5Bcategory%5D/%5BhybidPage%5D-906e4671b95c6b73efa5.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/d28ceec4db7051e92ba475fb3036a40cc4838886/_buildManifest.js" async=""></script><script src="https://www.gamedeveloper.com/_next/static/d28ceec4db7051e92ba475fb3036a40cc4838886/_ssgManifest.js" async=""></script><link href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.15.2/css/all.min.css" rel="stylesheet"/><script async="" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script></body></html>